Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]
Connect MTS modem to Keenetic Giga — Protocol error - bug-code.com Q&A

Connect MTS modem to Keenetic Giga — Protocol error

0 like 0 dislike
54 views
Dear hebraically!

1) There is a router ZyXEL Keenetic Giga, updated to the latest stable firmware.
2) Have the modem from MTS, ZTE MF 658. It is in the list supported by the router modem.

Now, click "connect". See: Initializing -> Connection -> Protocol Error. Then all over again.
The router defines the modem settings of the Internet everything is in place, there is a switch method of authentication (CHAP, PAP, PAP+CHAP) — tried all, not working.

A couple of times managed to connect and pings are passed, but as soon as I opened the web browser once everything is back passed out.

On the computer using the standard program the modem works.
asked by | 54 views

5 Answers

0 like 0 dislike
Looked in the error log?
Also, could you specify VID/PID of your modem? It is possible to look in the firmware what AT commands to router sends, they can be compared with those that he sends his driver under Windows.
answered by
0 like 0 dislike
Tell me, have dealt with the problem?
answered by
0 like 0 dislike
Nov 16 04:02:32 kernel: hub 1-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
Nov 16 04:02:32 kernel: usb 1-1: USB disconnect, address 2
Nov 16 04:02:32 kernel: usb 1-1.2: USB disconnect, address 4

Based on this, I can say that the modem is not enough power.
Try connecting it via USB hub with external power, should help.
answered by
0 like 0 dislike
Try to directly insert the modem into the router, without using a hub or USB extension cable
answered by
0 like 0 dislike
Good time of day. Sorry for necroposting, but faced with the same problem as the author: a Protocol error when working with MTS, the same modem with the SIM card MegaFon works perfectly.
\r
The only thing I have dir-620 altered in Kinetik.
\r
Here are the logs: pastebin.com/hvu1Fm2R and pastebin.com/E5cVZ7qR
answered by
Welcome to Bug-code Q&A, where you can ask questions and receive answers from other members of the community.

24.8k questions

46.2k answers

0 comments

12.7k users

24,788 questions
46,220 answers
0 comments
12,720 users